Fejlagtig opdatering af WordPress - 9bureau

Oplevede I en mærkelig opdatering af jeres WordPress i går?

Blev jeres WordPress installation pludselig opdateret til WordPress alfaversion 5.5.3-alpha-49449?

Det skyldes en fejlagtig opdatering af WordPress til version 5.5.2, der blev udsendt den 29. oktober 2020.

En fejl i WordPress version 5.5.2 fik WordPress til at auto-opdatere til en alfa-version af WordPress og flere andre kedelige ting.

WordPress er nu rettet igen.

Straks-opdatering udsendt i går

Derfor måtte WordPress-core team i går den 30. oktober 2020 udsende WordPress 5.5.3, der er en straks opdatering til WordPress 5.5.2, som blev udsendt dagen før den 29. okotber 2020.

Straks-opdateringen blev udsendt for at afhjælpe afhjælpe et problem i WordPress 5.5.2, der blandt andet gjorde det umuligt at installere WordPress på et nyt websted uden en databaseforbindelse konfigureret.

Uvarslet opdatering til alfaversion 5.5.3-alpha-49449

Samtidig førte en fejl til at nogle WordPress websteder fejlagtigt blev opdateret til version 5.5.3-alpha.

Her på 9bureau oplevede dette vi både at vores eget WordPress websted og en række kunders WordPress websteder pludselig blev opdateret til WordPress alfaversion 5.5.3-alpha-49449

Ifølge frigivelsesnoterne fra wordpress.org opdaterede WordPress automatiske opdateringssystem i går den 30. oktober nogle websteder fra version 5.5.2 til alfaversion 5.5.3-alpha.

Problemerne opstod, da WordPress Core-teamet deaktiverede download af WordPress version 5.5.2-udgivelsen i et forsøg på at forhindre nye brugere i at bruge denne version.

Ved at deaktivere download af 5.5.2 returnerede wordpress.org API alfaversion 5.5.3-alpha-49449 som den version, som WordPress skulle opdatere til.

Ingen grund til panik

Core-teams analyse af 5.5.3-alpha-49449-udgivelsen fandt kun en meget lille forskel mellem WordPress 5.5.2-udgivelsen og WordPress 5.5.3-alpha-49449, fordi meget af kernefunktionaliteten er den samme.

Der har ikke været rapporter om tab af hverken funktionalitet eller data pga. fejlen.

Den automatiske opdatering til WordPress alfaversion 5.5.3-alpha-49449 gjorde uimidlertid at der blev installeret et antal yderligere Twenty Twenty temaer sammen med Akismet-pluginet på nogle WordPress installationer.

Core-teamet gen-aktiverede muligheden for download af WordPress version 5.5.2 for at forhindre websteder i at opdatere til alfa-versionen.

Samtidig udsendte Core-team så en starks-opdatering af WordPress med ​​WordPress 5.5.3 for at løse det problem, der forhindrede nye installationer.

Hvad kan du gøre?

Hvis jeres WordPress websted blev opdateret til WordPress 5.5.3-alpha, kan der være kommet flere temaer på jeres websted.

Måske er Akismet pluginen også blevet installeret.

Begge dele er mere et irritationsmoment end en alvorlig fejl.

I behøver ikke gøre andet end at se efter om der pludselig er kommet flere temaer i jeres WordPress, og hvis der er, så kan I blot slette dem i WordPress.

Det samme kan I gøre med Akismet, men Akismet er jo en god ting, så hvorfor ikke overveje at lade den blive?

Opdater til WordPress 5.5.3

Opdater WordPress til version 5.5.3 hvis I ikke allerede har gjort det.

Hvis auto-opdateringer er slået til i jeres WordPress, så er 5.5.3-versionen muligvis allerede installeret.

Hvis I endnu ikke har opdateret til WordPress version 5.5.2, så er opdateringen tilversion 5.5.3 stort set den samme version – med en mindre rettelse…

Fejlagtig opdatering af WordPress – behøver I hjælp?

Hvis I har brug for assistance i forbindelse med den fejlagtige opdatering af WordPress, som wordpress.org selv er skyld i, så kan I altid kontakte os her på 9bureau.

Hvis I ønsker en helt uforpligtende snak om hvilke muligheder, der er for at få en ny WordPress hjemmeside eller andet, så kontakt os endelig.

Kontakt os

Brug formularen herunder, så vender vi tilbage hurtigst muligt.